Technical / System Requirements

This is a list of basic computer system requirements to use our Learner Management System (Canvas).

It is always recommended to use the most up-to-date versions and better connections. Our Learner Management System will still run with the minimum specifications, but you may experience slower loading times.

Our Learner Management System and its hosting infrastructure are designed for maximum compatibility and minimal requirements.

  System Specs


Operating System

Windows 7 and newer (users on Windows 10 need to download the Windows 10 Anniversary Update to submit assignments)

Mac OSX 10.6 and newer

Linux – chromeOS

Tablet, Phone OS

iOS 7 and newer (versions vary by device)

Android 4.2 or newer

Computer Speed & Processor
 
 
 
 
Internet Speed

Use a computer 5 years old or newer when possible

1GB of RAM

2GHz Processor

Along with the compatibility and web standards, our Learner Management System has been carefully crafted to accommodate low bandwidth environments – Minimum of 512kbps

Screen Resolution

1366 x 768 and higher

Audio

Speakers / Headphones

Webcam

Good quality webcam to take clips of your practical tasks (if not using mobile / tablet)

  Supported Browsers

Our Learner Management System support the current and first previous major releases of the following browsers:


Internet Explorer 11 and Edge 39 and 40

Windows only – please make sure your operating system is also current as noted in the computer specifications, you may need to download the Windows 10 Anniversary Update to submit assignments

Safari 9 and 10

Macintosh only

Chrome 58 and 59

Firefox 53 and 54

Extended Releases are not supported

Flash 25 and 26

Used for recording or viewing audio/video and uploading files

Responds Lockdown Browser

Supporting the latest system requirements

We highly recommend updating to the most current version of your preferred browser. Your browser will notify you if there is a new version available. Some supported browsers may still produce a banner stating “Your browser does not meet the minimum requirements for Canvas”. If you have upgraded your browser but you are still seeing the warning banner, try logging out of the Learner Management System and deleting your browser cookies.

  Required Components


Is required for recording audio and video in the Learner Management System. Other than these features, Flash is not required to use in most areas of the Learner Management System.
Please note that some browsers may no longer support flash.

Is required for screen sharing in Conferences.
Please note that some browsers do not support Java.

**JavaScript must be enabled to run the Learner Management System

  For Media File Downloads Only


Excel

2003+

Word

2003+

PDF Reader

All pdf readers acceptable